当前位置: 首页 > 网络技术 > 正文

CCNA认证学习笔记5-RIP

简单介绍下Rip , Rip Router information protocol 路由信息协议,属于动态路由协议,使用贝尔曼福特算法 ,这个算法也是距离矢量路由协议使用的算法,另外IGRP也属于 距离矢量路由协议
  • RIP有两个版本,RIPv1和RIPV2,其中RIP V1属于有类路由协议,RIP V2属于无类路由协议,默认支持的负载均衡是4条,最大支持6条最大跳数为15,超过15默认为不可达,
  • RIP共有四个计时器,他们分别是 更新定时器,失效定时器,抑制定时器,和刷新定时器他们默认的时间间隔分别是 30s 180s 180s 240s在某个网路失效后,四个定时器同时启动,在失效定时器超时之前,发往网络的数据包同样转发,在失效定时器个超时后,发往网络的数据包不再转发,直到刷新定时器超时将该路由从路由表中删除
  • RIP 受接收到的路由信息都封装在UDP报文中,使用UDP端口520来接受路由信息
  • RIP V1基本特性:1.有类路由协议,不支持VLSM和CIDR,也就是可变长子网掩码和无类域间路由,不支持不连续的子网,无法关闭自动汇总,使用广播来更新路由,没隔一段时间 (默认是30s)发送路由表,不论是否有更改;发送路由更新不携带子网掩码,在主类网络边界自动汇总,在非主类网络的边界不会自动汇总;当从一个接口接收到同一个主类网络的子网路由时,默认收到的子网的路由和接口的子网掩码相同;接受RIP V1和RIP V2的路由更新信息,发送V1版本,
  • 什么是边界呢?路由器在传送路由时,如果传送的路由和路由器传播接口的IP地址所在的网络号不相同同,路由器将自动汇总要传送的路由为主类路由在传送出去,RIP V1在 传送接口的IP的主类网络号和要传送的路由的主类网络号相同的话,RIPV1不会汇总
  • RIP V2基本特性与RIP V1相比,V2是无类路由协议,支持VLSM和CIDR,使用组播地址进行更新,组播地址为:224.0.0.9,使用外部路由标记,支持身份验证,验证方式包含了MD5和明文验证,可以关闭自动汇总,支持手工汇总
  • RIP V1配置:
    Router(config)#router rip
    Router(route-config)#network 要宣告的网络的主类网络
    例如要宣告 12.1.1.0 /24 网络,那么命令就为
    network 12.0.0.0
    后面的依次类推
  • RIP V2配置
    Router(config)#router rip
    Router(route-config)#version 2
    Router(route-config)#no auto //关闭自动汇总,可选项
    Router(route-config)#network 要宣告的网络的主类网络
  • RIP配置负载均衡 (路由进程下)
    Router(config)#router rip
    Router(route-config)#maximum-paths 6 //配置为支持六条线路
  • RIP关闭水平分割 (端口进程下)
    router(config)#int fa 0/0
    router(config-if)#no ip split-horizon
  • RIP的被动端口设置(路由进程下)
    Router(config)#router rip
    Router(router-config)#passive-interface loopback 0 //将loopback0设定为被动端口,只接受路由更新,不发送
  • RIP缺省路由配置(路由进程下宣告默认路由,在加上一条静态路由即可)
    Router(config)#router rip
    Router(route-config)#default-information originate //宣告默认路由
    RouterRouter(route-config)#exit //退回到全局配置模式
    Router(config)#ip route 0.0.0.0 0.0.0.0 下一跳的IP或者是发出端口   //静态默认路由或者直接宣告外出接口的网络为默认网络也可以
    Router(config)#ip default-network  外出接口的主类网络 //一样可以宣告缺省路由
  • RIP更改计时器(路由进程下)
    Router(config)#router rip
    Router(router-config)# timer basic 更新定时器值 失效定时器 抑制定时器 刷新定时器
  • IP借用 (配置在串行链路上 ,并且因为串行链路两端的处于不同网络,依次需要各自配置一条指向对方的静态路由)
    router(config)#int s0/0
    router(config-if)#ip unnumbered 要借用的端口
  • RIP v2手工汇总(要发送路由更新到其他路由器的端口进程下)
    router(config)#int s0/0
    router(config-if)#ip summary-address rip 汇总后的网络地址 汇总后的子网掩码
  • RIP V2验证 (思路:先在端口进程中声明用什么验证方式(假设为MD5),然后全局配置模式生成一个密钥链 ,再在端口进程下调用密钥链,)


本文固定链接: http://kuaile.in/archives/445 | 蒲公英的博客

该日志由 蒲公英 于2012年02月11日发表在 网络技术 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: CCNA认证学习笔记5-RIP | 蒲公英的博客
关键字:

CCNA认证学习笔记5-RIP:等您坐沙发呢!

发表评论


You must enable javascript to see captcha here!

快捷键:Ctrl+Enter